summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-02-21 13:33:20 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-03-06 03:22:30 +0100
commitec0742133297ac02b684ee1e81d1143de06956f7 (patch)
tree99987282c3812203a5415db99be21b166d5e1619 /gnu
parent7bc19c92054b7b6d5a9268a7f2d3344adf04cce4 (diff)
downloadguix-ec0742133297ac02b684ee1e81d1143de06956f7.tar.gz
gnu: Add python2-backports-shutil-get-terminal-size.
* gnu/packages/python.scm (python2-backports-shutil-get-terminal-size): New
variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5631c7ac0b..0d1dd18a58 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -33,7 +33,7 @@
 ;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2016, 2017 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
 ;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
 ;;;
@@ -6087,6 +6087,29 @@ connection to each user.")
 (define-public python2-backports-abc
   (package-with-python2 python-backports-abc))
 
+(define-public python2-backports-shutil-get-terminal-size
+  (package
+    (name "python2-backports-shutil-get-terminal-size")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "backports.shutil_get_terminal_size" version))
+       (sha256
+        (base32
+         "107cmn7g3jnbkp826zlj8rrj19fam301qvaqf0f3905f5217lgki"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2))
+    (home-page "https://github.com/chrippa/backports.shutil_get_terminal_size")
+    (synopsis "Backport of Python 3.3's @code{shutil.get_terminal_size}")
+    (description
+     "This package provides a backport of the @code{get_terminal_size
+function} from Python 3.3's @code{shutil}.
+Unlike the original version it is written in pure Python rather than C,
+so it might be a tiny bit slower.")
+    (license license:expat)))
+
 (define-public python-waf
   (package
     (name "python-waf")