summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:42:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:42:46 +0200
commitf0c6810007ffafeab4e498df8e78df310afb50bc (patch)
treee5719fd6b6932343120717d92e6f674d60a4bd75 /gnu
parent7a0346654d34479878f35556852f89c1f2f6f6c6 (diff)
downloadguix-f0c6810007ffafeab4e498df8e78df310afb50bc.tar.gz
gnu: eolie: Don't create icon cache.
* gnu/packages/gnome.scm (eolie)[arguments]: Add phase to skip creating
the gtk icon cache.
[native-inputs]: Remove gtk+:bin.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 862959534f..1e8dc77912 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4413,6 +4413,12 @@ almost all of them.")
      `(#:glib-or-gtk? #t
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "meson_post_install.py"
+               (("gtk-update-icon-cache") "true"))
+             #t))
          (add-after 'wrap 'wrap-more
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out  (assoc-ref outputs "out"))
@@ -4435,8 +4441,7 @@ almost all of them.")
        ("itstool" ,itstool)
        ("pkg-config" ,pkg-config)
        ("python" ,python)
-       ("glib:bin" ,glib "bin")
-       ("gtk+" ,gtk+ "bin")))
+       ("glib:bin" ,glib "bin")))
     (inputs
      `(("gobject-introspection" ,gobject-introspection)
        ("glib-networking" ,glib-networking)