summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-06 14:16:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-06 14:36:08 +0300
commit1123da369db5fa95fc306eac20ff4b7572384b87 (patch)
tree982cb33e1eabd42e6efda3cb85613523604d7fe4 /gnu
parent5cf81294c097a0c31cb2f5360e7e1e418407e065 (diff)
downloadguix-1123da369db5fa95fc306eac20ff4b7572384b87.tar.gz
gnu: links: Use configure-flags.
* gnu/packages/web-browsers.scm (links)[arguments]: Add configure-flags
field. Adjust custom 'configure phase to use configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web-browsers.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 07df9f7580..b761fa73a8 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -167,10 +167,11 @@ management, extensions such as advertisement blocker and colorful tabs.")
                 "1jy90k04kl7y3l8jzg5jx7fglyqzngng0964j7j67gjxy9vkanzh"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags '("--enable-graphics")
+       #:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda* (#:key outputs (configure-flags '()) #:allow-other-keys)
              ;; The tarball uses a very old version of autoconf. It doesn't
              ;; understand extra flags like `--enable-fast-install', so
              ;; we need to invoke it with just what it understands.
@@ -180,9 +181,9 @@ management, extensions such as advertisement blocker and colorful tabs.")
                      `((setenv "CHOST" ,(%current-target-system)))
                      '())
                (setenv "CONFIG_SHELL" (which "bash"))
-               (invoke "./configure"
-                       (string-append "--prefix=" out)
-                       "--enable-graphics")))))))
+               (apply invoke "./configure"
+                      (string-append "--prefix=" out)
+                      configure-flags)))))))
     (native-inputs (list pkg-config))
     (inputs `(("gpm" ,gpm)
               ("libevent" ,libevent)