summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-19 16:02:15 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-19 16:56:25 +0100
commit71bc9d195a110e014b86c7738e63ecd4a4edaabd (patch)
tree44fbf60ed53ca3df095f8cdf24c4939941d13c1d /gnu
parentdc33a21fc099909c076029081cafc8338cf14b8b (diff)
downloadguix-71bc9d195a110e014b86c7738e63ecd4a4edaabd.tar.gz
gnu: Add emacs-external-completion.
* gnu/packages/emacs-xyz.scm (emacs-external-completion): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6cd5d686cd..10b7229878 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4527,6 +4527,33 @@ create an Extempore REPL, connect the current @code{extempore-mode} buffer to a
 running Extempore process, and more.")
       (license license:bsd-2))))
 
+(define-public emacs-external-completion
+  (package
+    (name "emacs-external-completion")
+    (version "0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://elpa.gnu.org/packages/external-completion-" version
+                    ".tar"))
+              (sha256
+               (base32
+                "12pddwp5jby2icshj77w4kwxv75zi00jdxw18f721d7zx3l7q668"))))
+    (build-system emacs-build-system)
+    (home-page "https://elpa.gnu.org/packages/external-completion.html")
+    (synopsis "Let external tools control Emacs completion style")
+    (description
+     "The @code{external} completion style is used with a ``programmable
+completion'' table that gathers completions from an external tool such as
+a shell utility, an inferior process, an HTTP server.  The table and external
+tool are fully in control of the matching of the pattern string to the
+potential candidates of completion.  When @code{external} is in use, the usual
+styles configured by the user or other in @code{completion-styles} are
+ignored.  This compromise is for speed: all other styles need the full data
+set to be available in Emacs addressing space, which is often slow if not
+completely unfeasible.")
+    (license license:gpl3+)))
+
 (define-public emacs-kakoune
   ;; Package has no release.  Version is extracted from "Version:" keyword in
   ;; main file.