summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2022-01-06 15:33:58 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-11 20:35:00 +0100
commitd07d3ea008d24f8ad5f4f32f86cb1f89226123ae (patch)
tree24a2607ef97e856250ef10ced53d2660db24049b /gnu
parent92c873e38a9716d339fd7b0bcf37c6c2da6baf24 (diff)
downloadguix-d07d3ea008d24f8ad5f4f32f86cb1f89226123ae.tar.gz
gnu: python-msgpack-transitional: Fix broken tests.
* gnu/packages/python-xyz.scm (python-msgpack-transitional)[arguments]:
Replace references to deprecated Python methods.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 36434a4707..cf6f17493e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10870,6 +10870,11 @@ reading and writing MessagePack data.")
                (substitute* "setup.py"
                  (("TRANSITIONAL = False")
                    "TRANSITIONAL = 1"))
+               ;; This old version is not compatible with Python 3.9
+               (substitute* '("test/test_buffer.py" "test/test_extension.py")
+                 ((".tostring\\(") ".tobytes("))
+               (substitute* '("test/test_buffer.py" "test/test_extension.py")
+                 ((".fromstring\\(") ".frombytes("))
                #t))))))))
 
 (define-public python2-msgpack