summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-13 11:33:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:45 -0400
commit10d69f20be51c25deebb8086a6391c11b2c29a5b (patch)
tree1252ef7d1785ef331e1fa031872e92736b960159 /gnu
parent4bc0d5300bcf07aa7ff7049350262e6d65a85ff2 (diff)
downloadguix-10d69f20be51c25deebb8086a6391c11b2c29a5b.tar.gz
gnu: python-bleach: Update to 5.0.0.
* gnu/packages/python-xyz.scm (python-bleach): Update to 5.0.0.
[propagated-inputs]: Remove python-packaging and python-six.  Add
python-tinycss2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 60c2e0e3cd..905086f133 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13441,23 +13441,21 @@ systems, as a command line tool, and as a Python library.")
 (define-public python-bleach
   (package
     (name "python-bleach")
-    (version "4.1.0")
+    (version "5.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "bleach" version))
        (sha256
-        (base32 "1nkibazmw1ry4cfxs9qrkkidxdf2z1hh1b20xq1ahqdsgsrxh009"))))
+        (base32 "0rc5avysbsl3w3i2qvb6522263zhwlvf50w0ifs8776w9c2wrmn6"))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
                   (replace 'check
                     (lambda* (#:key tests? #:allow-other-keys)
                       (when tests? (invoke "pytest" "-vv")))))))
-    (propagated-inputs
-     (list python-packaging python-six python-webencodings))
-    (native-inputs
-     (list python-pytest))
+    (propagated-inputs (list python-tinycss2 python-webencodings))
+    (native-inputs (list python-pytest))
     (home-page "https://github.com/mozilla/bleach")
     (synopsis "Whitelist-based HTML-sanitizing tool")
     (description "Bleach is an easy whitelist-based HTML-sanitizing tool.")