summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-04-04 19:53:10 -0400
committerLeo Famulari <leo@famulari.name>2022-04-04 19:57:12 -0400
commit20303c0b1c75bc4770cdfa8b8c6b33fd6e77c168 (patch)
treebaecab5efacacdcb0ab8dd7acf3c3b3168103801 /gnu
parentb1e7e64f351fa03a66ce1f9776f9ba84cf2c6294 (diff)
downloadguix-20303c0b1c75bc4770cdfa8b8c6b33fd6e77c168.tar.gz
gnu: eyeD3: Update to 0.9.6.
* gnu/packages/mp3.scm (eyed3): Update to 0.9.6.
[propagated-inputs]: Add python-deprecation and python-filetype.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mp3.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index b95de712b0..4a8bdad711 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -561,18 +561,23 @@ compression format (.mpc files).")
 (define-public eyed3
   (package
     (name "eyed3")
-    (version "0.8.12")
+    (version "0.9.6")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "eyeD3" version))
        (sha256
-        (base32 "0vabr7hh6vy1w8gn35vmx9qwiyrfv734d5ahifg7x3pv0c5fqkp5"))))
+        (base32 "063mpg5bks9dgggjyag8968z5r7z4x50s0m0rja956dk1zn68l2b"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f))    ; the required test data contains copyrighted material
     (propagated-inputs
-     (list python-grako python-magic python-pathlib python-six))
+     (list python-deprecation
+           python-filetype
+           python-grako
+           python-magic
+           python-pathlib
+           python-six))
     (synopsis "MP3 tag ID3 metadata editor")
     (description "eyeD3 is a Python tool for working with audio files,
 specifically mp3 files containing ID3 metadata (i.e. song info).  It provides a