summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@posteo.net>2021-12-27 22:53:46 -0600
committerEric Bavier <bavier@posteo.net>2021-12-27 22:53:46 -0600
commit2c451db39aabc69bdbf186f412ee6e0b4e180ccb (patch)
tree26fdf665cde172e10ef0e71bddd39303ee1ac5bd /gnu
parentd435402e84aeb9f6229e2af19fe2be228de8dd04 (diff)
downloadguix-2c451db39aabc69bdbf186f412ee6e0b4e180ccb.tar.gz
gnu: cool-retro-term: Fix build with gcc@10.
* gnu/packages/patches/cool-retro-term-wctype.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/terminals.scm (cool-retro-term)[source]: Add
'cool-retro-term-wctype.patch'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/cool-retro-term-wctype.patch13
-rw-r--r--gnu/packages/terminals.scm3
3 files changed, 16 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4b94f7f8e5..fc8927df9f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -962,6 +962,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/collectd-5.11.0-noinstallvar.patch		\
   %D%/packages/patches/combinatorial-blas-awpm.patch		\
   %D%/packages/patches/combinatorial-blas-io-fix.patch		\
+  %D%/packages/patches/cool-retro-term-wctype.patch		\
   %D%/packages/patches/coreutils-gnulib-tests.patch		\
   %D%/packages/patches/coq-fix-envvars.patch			\
   %D%/packages/patches/coreutils-ls.patch			\
diff --git a/gnu/packages/patches/cool-retro-term-wctype.patch b/gnu/packages/patches/cool-retro-term-wctype.patch
new file mode 100644
index 0000000000..790b0c4453
--- /dev/null
+++ b/gnu/packages/patches/cool-retro-term-wctype.patch
@@ -0,0 +1,13 @@
+Submitted upstream at https://github.com/Swordfish90/cool-retro-term/issues/692
+
+--- a/qmltermwidget/lib/TerminalCharacterDecoder.cpp	1969-12-31 18:00:01.000000000 -0600
++++ b/qmltermwidget/lib/TerminalCharacterDecoder.cpp	2021-12-27 22:07:04.452256118 -0600
+@@ -19,6 +19,8 @@
+     02110-1301  USA.
+ */
+ 
++#include <cwctype>
++
+ // Own
+ #include "TerminalCharacterDecoder.h"
+ 
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 16b33385bc..be8d586669 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -13,7 +13,7 @@
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018, 2019 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018, 2019, 2021 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
@@ -673,6 +673,7 @@ embedded kernel situations.")
                            (srfi srfi-26)
                            (ice-9 rdelim)
                            (ice-9 regex)))
+                (patches (search-patches "cool-retro-term-wctype.patch"))
                 (snippet
                  '(let* ((fonts '(;"1971-ibm-3278"     ; BSD 3-clause
                                   "1977-apple2"        ; Non-Free