summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-22 20:12:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-22 20:14:15 +0100
commit6aff67f90d05fa7d2ab31f32ea7d944bf3ea61a9 (patch)
treec52e669a018abb17674c6965074bb0765cafda7b /gnu
parentf010692a274527303ea1feecd40bc20645a75c15 (diff)
downloadguix-6aff67f90d05fa7d2ab31f32ea7d944bf3ea61a9.tar.gz
gnu: Add r-itsadug.
* gnu/packages/cran.scm (r-itsadug): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dd73676622..9679b3c664 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8948,6 +8948,36 @@ patterned after functions in the Python @code{itertools} module, and others
 patterned after functions in the snow package.")
     (license license:gpl2)))
 
+(define-public r-itsadug
+  (package
+    (name "r-itsadug")
+    (version "2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "itsadug" version))
+       (sha256
+        (base32 "0759l7hhvj05dp92pz59xwrxjm9s1iwkwrdhs68l0fq57550j70l"))))
+    (properties `((upstream-name . "itsadug")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-mgcv r-plotfunctions))
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/package=itsadug")
+    (synopsis "Interpreting time series and autocorrelated data using GAMMs")
+    (description
+     "@dfn{Generalized Additive Mixed Modeling} (GAMM; Lin & Zhang, 1999) as
+implemented in the R package @code{mgcv} is a nonlinear regression analysis
+which is particularly useful for time course data such as EEG, pupil dilation,
+gaze data (eye tracking), and articulography recordings, but also for
+behavioral data such as reaction times and response data.  As time course
+measures are sensitive to autocorrelation problems, GAMMs implements methods
+to reduce the autocorrelation problems.  This package includes functions for
+the evaluation of GAMM models (e.g., model comparisons, determining regions of
+significance, inspection of autocorrelational structure in residuals) and
+interpreting of GAMMs (e.g., visualization of complex interactions, and
+contrasts).")
+    (license license:gpl2+)))
+
 (define-public r-polynom
   (package
     (name "r-polynom")