summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-04 21:22:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-04 21:22:59 +0100
commit6f1b958e1a9c9a148172715ccbed304077b6d2d7 (patch)
tree39951772ef4bcc07bf5084bd81480a25315a6a59 /gnu
parentc4bb48958de56c7b8fb43ff58601b215fb286cb4 (diff)
downloadguix-6f1b958e1a9c9a148172715ccbed304077b6d2d7.tar.gz
gnu: Add r-data-tree.
* gnu/packages/cran.scm (r-data-tree): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 34714677d7..e650c56536 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6664,6 +6664,33 @@ data-frames, visualize the graph on a web browser through gexf-js (a
 JavaScript library) and interact with the igraph package.")
     (license license:expat)))
 
+(define-public r-data-tree
+  (package
+    (name "r-data-tree")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "data.tree" version))
+       (sha256
+        (base32
+         "0pizmx2312zsym4m42b97q2184bg3hibvbdrblcga05xln84qrs0"))))
+    (properties `((upstream-name . "data.tree")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-r6" ,r-r6)
+       ("r-stringi" ,r-stringi)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "http://github.com/gluc/data.tree")
+    (synopsis "General purpose hierarchical data structure")
+    (description
+     "Create tree structures from hierarchical data, and traverse the tree in
+various orders.  Aggregate, cumulate, print, plot, convert to and from
+data.frame and more.  This is useful for decision trees, machine learning,
+finance, conversion from and to JSON, and many other applications.")
+    (license license:gpl2+)))
+
 (define-public r-rappdirs
   (package
     (name "r-rappdirs")