summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-07-05 17:31:10 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-07-31 23:05:59 +0200
commit96707d5a309d083b1a9bf1f0c8fc1251cf203337 (patch)
tree791cbb5e031accd5a8224ab3e3aa6cb3668ce604 /gnu
parent7c6ace67bb8ef421965e3f1cc1a02caf54c813f5 (diff)
downloadguix-96707d5a309d083b1a9bf1f0c8fc1251cf203337.tar.gz
gnu: ocaml-zarith: Update to 1.12.
* gnu/packages/ocaml.scm (ocaml-zarith): Update to 1.12.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 727c7a08c8..f75755cfd6 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1429,7 +1429,7 @@ files in these formats.")
 (define-public ocaml-zarith
   (package
     (name "ocaml-zarith")
-    (version "1.9.1")
+    (version "1.12")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1438,7 +1438,7 @@ files in these formats.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0hv5ywz1q2cgn8apfz490clwk5hcynr937g2v8i13x2ax4bnv0lz"))))
+                "1jslm1rv1j0ya818yh23wf3bb6hz7qqj9pn5fwl45y9mqyqa01s9"))))
     (build-system ocaml-build-system)
     (native-inputs
      `(("perl" ,perl)))
@@ -1449,7 +1449,14 @@ files in these formats.")
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda _ (invoke "./configure"))))))
+           (lambda _ (invoke "./configure")))
+         (add-after 'install 'move-sublibs
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (lib (string-append out "/lib/ocaml/site-lib")))
+               (mkdir-p (string-append lib "/stublibs"))
+               (rename-file (string-append lib "/zarith/dllzarith.so")
+                            (string-append lib "/stublibs/dllzarith.so"))))))))
     (home-page "https://forge.ocamlcore.org/projects/zarith/")
     (synopsis "Implements arbitrary-precision integers")
     (description "Implements arithmetic and logical operations over