summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-12 13:22:13 -0400
committerLeo Famulari <leo@famulari.name>2016-10-12 13:24:51 -0400
commit9ebe87fe592682b3a3ba65974a2238f14a77cda2 (patch)
tree6f208e256adde8d4c7e6c5f54c2c30b8e03aa234 /gnu
parenta6bb9e446f4df3c220296041e08814a492494c2e (diff)
downloadguix-9ebe87fe592682b3a3ba65974a2238f14a77cda2.tar.gz
gnu: python-celery: Update to 3.1.24.
* gnu/packages/python.scm (python-celery, python2-celery): Update to 3.1.24.
[arguments]: Disable some tests with break with Python 3.5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a9783b62ad..f1bdee28b8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8498,15 +8498,24 @@ Python 2.4 and 2.5, and will draw its fixes/improvements from python-trunk.")
 (define-public python-celery
   (package
     (name "python-celery")
-    (version "3.1.20")
+    (version "3.1.24")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "celery" version))
        (sha256
         (base32
-         "1md6ywg1s0946qyp8ndnsd677wm0yax933h2sb4m3a4j7lf1jbyh"))))
+         "0yh2prhdnx2dgkb67a5drj12hh2zvzx5f611p7mqqg01ydghif4r"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; These tests break with Python 3.5:
+         ;; https://github.com/celery/celery/issues/2897#issuecomment-253066295
+         (replace 'check
+           (lambda _
+             (zero?
+               (system* "nosetests" "--exclude=^test_safe_to_remove.*")))))))
     (native-inputs
      `(("python-nose" ,python-nose)))
     (inputs