summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-09-06 16:06:48 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-06 23:27:40 +0200
commitb60a7f049c2aa6d2d6462515e25476cf9a421427 (patch)
tree95f424d778b79d332bb95b8f7c017b7a8694977b /gnu
parentc80e71a5868556f737ba93c70f5050e9ed0a55c2 (diff)
downloadguix-b60a7f049c2aa6d2d6462515e25476cf9a421427.tar.gz
gnu: ocamlformat: Update to 0.19.0.
* gnu/packages/ocaml.scm (ocamlformat): Update to 0.19.0.
[propagated-inputs]: Add ocaml-odoc-parser.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2d6743f217..b6c9559d6e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7145,7 +7145,7 @@ get an precise reference of when the executable was built.")))
 (define-public ocamlformat
   (package
     (name "ocamlformat")
-    (version "0.18.0")
+    (version "0.19.0")
     (source
       (origin
         (method git-fetch)
@@ -7155,7 +7155,7 @@ get an precise reference of when the executable was built.")))
         (file-name (git-file-name name version))
         (sha256
           (base32
-            "0n6363km8xr81pvyk453n6h2mb0256c5yxw3p1li4dn83f3lwxr1"))))
+            "0dp4pkznz9yvqx9gxwbid1z2b8ajkr8i27zay9ghx69624hz3i4z"))))
     (build-system dune-build-system)
     (arguments
      '(#:package "ocamlformat"
@@ -7173,6 +7173,7 @@ get an precise reference of when the executable was built.")))
         ("ocaml-odoc" ,ocaml-odoc)
         ("ocaml-ppxlib" ,ocaml-ppxlib)
         ("ocaml-re" ,ocaml-re)
+        ("ocaml-odoc-parser" ,ocaml-odoc-parser)
         ("ocaml-stdio" ,ocaml-stdio)
         ("ocaml-uuseg" ,ocaml-uuseg)
         ("ocaml-uutf" ,ocaml-uutf)))