summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-12-22 02:10:32 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-12-22 02:34:03 +0100
commit0770201a204a2c4d708334508833a4a69e6c5504 (patch)
tree4b53935122239f8e7891936ae29c3e63856fac99 /gnu
parent2317a5e17fe643328c5fed0d6ea0e542703c0ace (diff)
downloadguix-0770201a204a2c4d708334508833a4a69e6c5504.tar.gz
gnu: camlp5: Update to 8.00.02.
* gnu/packages/ocaml.scm (camlp5): Update to 8.00.02.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5247061bf1..22e7437633 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -882,19 +882,17 @@ Git-friendly development workflow.")
 (define-public camlp5
   (package
     (name "camlp5")
-    (version "7.13")
+    (version "8.00.02")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/camlp5/camlp5")
-             (commit (string-append "rel" (string-delete #\. version)))))
+             (commit (string-append "rel" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1d9spy3f5ahixm8nxxk086kpslzva669a5scn49am0s7vx4i71kp"))))
+        (base32 "03qm99h2380x0y69sppg10yz1mwx7smkscia7pa175wmilifx8vy"))))
     (build-system gnu-build-system)
-    (inputs
-     (list ocaml))
     (arguments
      `(#:tests? #f  ; XXX TODO figure out how to run the tests
        #:phases
@@ -924,6 +922,10 @@ Git-friendly development workflow.")
              (install-file "etc/META" (string-append (assoc-ref outputs "out")
                                                      "/lib/ocaml/camlp5/"))
              #t)))))
+    (inputs
+     (list ocaml))
+    (native-inputs
+     (list perl))
     (home-page "https://camlp5.github.io/")
     (synopsis "Pre-processor Pretty Printer for OCaml")
     (description