summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-21 10:26:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-21 10:27:34 +0100
commit21219307febfd6a9ed6036fdf0d78194292a3e14 (patch)
tree4be4b18901e305dd1e41bb2ad8f54db1247a2a19 /gnu
parent2bbc3864c3efd21e20d57f2c0e82bc53931bc15e (diff)
downloadguix-21219307febfd6a9ed6036fdf0d78194292a3e14.tar.gz
gnu: opencv: Fix installation.
This is a follow-up to commit 5894b1210d689ec408db21184b85b0a6a1a5ca3e.

* gnu/packages/image-processing.scm (opencv)[arguments]: Add build phase
'do-not-install-3rdparty-file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image-processing.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 32816187e1..046047880a 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -498,15 +498,19 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
                                "../opencv-extra")
              (copy-recursively (assoc-ref inputs "opencv-contrib")
                                "../opencv-contrib")))
-       (add-before 'check 'start-xserver
-         (lambda* (#:key inputs #:allow-other-keys)
-           (let ((xorg-server (assoc-ref inputs "xorg-server"))
-                 (disp ":1"))
-             (setenv "HOME" (getcwd))
-             (setenv "DISPLAY" disp)
-             ;; There must be a running X server and make check doesn't start one.
-             ;; Therefore we must do it.
-             (zero? (system (format #f "~a/bin/Xvfb ~a &" xorg-server disp)))))))))
+         (add-after 'build 'do-not-install-3rdparty-file
+           (lambda _
+             (substitute* "cmake_install.cmake"
+               (("file\\(INSTALL .*source/3rdparty/include/opencl/LICENSE.txt.*") "\n"))))
+         (add-before 'check 'start-xserver
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((xorg-server (assoc-ref inputs "xorg-server"))
+                   (disp ":1"))
+               (setenv "HOME" (getcwd))
+               (setenv "DISPLAY" disp)
+               ;; There must be a running X server and make check doesn't start one.
+               ;; Therefore we must do it.
+               (zero? (system (format #f "~a/bin/Xvfb ~a &" xorg-server disp)))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("xorg-server" ,xorg-server-for-tests) ; For running the tests