summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-22 09:56:20 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-26 12:31:40 +0100
commit4ae8180ca669a00ad6050936a1e541f6c3fa321a (patch)
treec220a22bacef692256a7340d27d6c051aaddba72 /gnu
parentd1e4e64cd788b2a7179d0ca5e5c5d3a4518bfa51 (diff)
downloadguix-4ae8180ca669a00ad6050936a1e541f6c3fa321a.tar.gz
gnu: python-pyqt: Fix output directory for plugins.
This defaults to QT_INSTALL_PLUGINS, thus we should use the same
sub-directory ($out/lib/qt5/plugins) here.

* gnu/packages/qt.scm (python-pyqt)[arguments]<phases>{configure}:
  Change base file name for plugins.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 241e73d575..c85fa93266 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1615,7 +1615,7 @@ module provides support functions to the automatically generated code.")
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin"))
                     (sip (string-append out "/share/sip"))
-                    (plugins (string-append out "/plugins"))
+                    (plugins (string-append out "/lib/qt5/plugins"))
                     (designer (string-append plugins "/designer"))
                     (qml (string-append plugins "/PyQt5"))
                     (python (assoc-ref inputs "python"))