summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-11 23:32:22 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:14 +0100
commitaa05f6a963ba2ec06e5daf1ecee054c0dfca77b3 (patch)
tree22d76a2fa75643d8670b68de92298b6d56ee47ea /gnu
parent789ef87470628e3188111cd7f6c01674a2edeb21 (diff)
downloadguix-aa05f6a963ba2ec06e5daf1ecee054c0dfca77b3.tar.gz
gnu: python-readme-renderer: Update to 32.0.
* gnu/packages/python-xyz.scm (python-readme-renderer): Update to 32.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 24675e8712..39957f9396 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25798,17 +25798,22 @@ positioning, and keyboard input.")
 (define-public python-readme-renderer
   (package
     (name "python-readme-renderer")
-    (version "26.0")
+    (version "32.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "readme_renderer" version))
         (sha256
          (base32
-          "13fnrv7z3y0yfafzcjbl55cqxncvbxadr72ql4l29pgyvrqxpsfb"))))
+          "11av194kgq6mvp2afpapkb6vyn3y14gingmgsp3n10krlspvw4mm"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests? (invoke "pytest" "-vv")))))))
     (propagated-inputs
-     (list python-bleach python-docutils python-pygments python-six))
+     (list python-bleach python-docutils python-pygments))
     (native-inputs
      (list python-mock python-pytest))
     (home-page "https://github.com/pypa/readme_renderer")