summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-02 20:41:05 +0200
committerMarius Bakke <marius@gnu.org>2021-05-09 23:43:02 +0200
commitcbc40ffa891257f7e7c89dcd82ecc136f764fca0 (patch)
treebc659e69ff7f419b7b75bc46884aad905e1f007f /gnu
parent9430debf2937c4c5f331720387e72a75df3fb662 (diff)
downloadguix-cbc40ffa891257f7e7c89dcd82ecc136f764fca0.tar.gz
gnu: glib: Disable SELinux support.
* gnu/packages/glib.scm (glib)[propagated-inputs]: Remove SELINUX.
[arguments]: Add "-Dselinux=false" to #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 573da30a21..801a2db4a9 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -64,7 +64,6 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
-  #:use-module (gnu packages selinux)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
@@ -201,7 +200,8 @@ shared NFS home directories.")
                "bin")) ; glib-mkenums, gtester, etc.; depends on Python
     (arguments
      `(#:disallowed-references (,tzdata-for-tests)
-       #:configure-flags '("-Dman=true")
+       #:configure-flags '("-Dman=true"
+                           "-Dselinux=disabled")
        #:phases
        (modify-phases %standard-phases
          ;; Needed to pass the test phase on slower ARM and i686 machines.
@@ -286,7 +286,6 @@ shared NFS home directories.")
        ("libelf" ,libelf)))
     (propagated-inputs
      `(("libffi" ,libffi) ; in the Requires.private field of gobject-2.0.pc
-       ("libselinux" ,libselinux) ; in the Requires.private field of gio-2.0.pc
        ("pcre" ,pcre)   ; in the Requires.private field of glib-2.0.pc
        ("util-linux" ,util-linux "lib") ;for libmount
        ("zlib" ,zlib))) ; in the Requires.private field of glib-2.0.pc