summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-27 23:30:36 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 18:07:32 +0100
commitdf1e2353df51fe1e8ff99724840b6fe3611a4cea (patch)
tree3249ba7b92ac85cb17f66423cde5880802d4f42d /gnu
parent07164966fe361f37496960747eac5a78288c66b7 (diff)
downloadguix-df1e2353df51fe1e8ff99724840b6fe3611a4cea.tar.gz
gnu: python-watchdog: Update to 2.1.6.
* gnu/packages/python-xyz.scm (python-watchdog): Update to 2.1.6.
[source]: Make some cosmetic changes.
[arguments]<#:phases>: Remove 'remove-failing phase. Override 'check phase and
skip a failing test.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d76d8dde13..11c3f0d6ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24502,23 +24502,24 @@ files.  These files are used to translate strings in android apps.")
 (define-public python-watchdog
   (package
     (name "python-watchdog")
-    (version "0.9.0")
+    (version "2.1.6")
     (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "watchdog" version))
-        (sha256
-         (base32
-          "07cnvvlpif7a6cg4rav39zq8fxa5pfqawchr46433pij0y6napwn"))))
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "watchdog" version))
+       (sha256
+        (base32 "1rx2nyl0cyj0v4ja795cl3gi26577c5wg48syr3byz3ndkgpavm3"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-before 'check 'remove-failing
-           (lambda _
-             (delete-file "tests/test_inotify_buffer.py")
-             (delete-file "tests/test_snapshot_diff.py")
-             #t)))))
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest" "-k"
+                       ;; This test failed.
+                       "not test_kill_auto_restart")))))))
     (propagated-inputs
      (list python-argh python-pathtools python-pyyaml))
     (native-inputs