summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-29 21:49:41 -0400
committerLeo Famulari <leo@famulari.name>2016-10-29 21:50:58 -0400
commit326f8285b35def19d4ce12ab9bb73d2b452c7760 (patch)
tree8e4daad9672427b477aba54a56382f6df998890e /gnu
parent062c7e43ed306c66f1107ee3bd52357aa8daf11a (diff)
downloadguix-326f8285b35def19d4ce12ab9bb73d2b452c7760.tar.gz
gnu: python-graphql-core: Disable the test suite.
The tests were silently skipped with Python 3.4. With Python 3.5, this caused
the build of python-graph-ql to fail.

* gnu/packages/python.scm (python-graphql-core,
python2-graphql-core)[arguments]: Disable the tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9dde9d3952..06f813098f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11079,7 +11079,8 @@ CPU, load, memory, network bandwidth, disk I/O, disk use, and more.")
           "0rsaarx2sj4xnw9966rhh4haiqaapm4lm2mfqm48ywd51j5vh1a0"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
+     `(#:tests? #f ; Tests require the unpackaged pytest-benchmark.
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-hardcoded-version
            (lambda _ (substitute*