summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-12 16:27:49 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-08 22:08:17 +1000
commitb16728b068ff9fda98b6f867a106a02bf5550364 (patch)
treefedc214a0ed3b4b506fe415fbce812a64248cc51 /gnu
parentdb7a344427637795b08728f4d5cdd6857682826d (diff)
downloadguix-b16728b068ff9fda98b6f867a106a02bf5550364.tar.gz
gnu: Add exonerate.
* gnu/packages/bioinformatics.scm (exonerate): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4450580199..661bacb203 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -52,6 +52,7 @@
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gd)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages groff)
   #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
@@ -1996,6 +1997,36 @@ in structured XML format.  This can eliminate the need for writing custom
 software to answer ad hoc questions.")
     (license license:public-domain)))
 
+(define-public exonerate
+  (package
+    (name "exonerate")
+    (version "2.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append
+         "http://ftp.ebi.ac.uk/pub/software/vertebrategenomics/exonerate/"
+         "exonerate-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0hj0m9xygiqsdxvbg79wq579kbrx1mdrabi2bzqz2zn9qwfjcjgq"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:parallel-build? #f)) ; Building in parallel fails on some machines.
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("glib" ,glib)))
+    (home-page
+     "https://www.ebi.ac.uk/about/vertebrate-genomics/software/exonerate")
+    (synopsis "Generic tool for biological sequence alignment")
+    (description
+     "Exonerate is a generic tool for pairwise sequence comparison.  It allows
+the alignment of sequences using a many alignment models, either exhaustive
+dynamic programming or a variety of heuristics.")
+    (license license:gpl3)))
+
 (define-public express
   (package
     (name "express")