summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 13:52:45 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 22:47:24 -0500
commitee28fc643249fa8c4f09134eb7a5360a03b41e10 (patch)
treef1e479715f4115c5d4890fc4af4d564a3292ffad /gnu
parent11163131cd948eee723ceb2d3ca19799fb434fed (diff)
downloadguix-ee28fc643249fa8c4f09134eb7a5360a03b41e10.tar.gz
gnu: glib: Update to 2.42.1.
* gnu/packages/glib.scm (glib): Update to 2.42.1.  Disable a test
  that requires dbus.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index e0f9acc7bb..c29a7008f9 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -119,7 +119,7 @@ shared NFS home directories.")
 (define glib
   (package
    (name "glib")
-   (version "2.40.2")
+   (version "2.42.1")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnome/sources/"
@@ -127,7 +127,7 @@ shared NFS home directories.")
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
-              "0ykcf99mhpkza3xwa3k79vgfml8mqiac9044802yi5q8jpr8mzz8"))
+              "16pqvikrps1fvwwqvk0qi4a13mfg7gw6w5qfhk7bhi8f51jhhgwg"))
             (patches (list (search-patch "glib-tests-homedir.patch")
                            (search-patch "glib-tests-desktop.patch")
                            (search-patch "glib-tests-prlimit.patch")
@@ -165,7 +165,12 @@ shared NFS home directories.")
                                  "glib/tests/utils.c"
                                  "tests/spawn-test.c")
                     (("/bin/sh")
-                     (string-append (assoc-ref inputs "bash") "/bin/sh"))))
+                     (string-append (assoc-ref inputs "bash") "/bin/sh")))
+
+                  ;; Disable a test that requires dbus.
+                  (substitute* "gio/tests/gdbus-serialization.c"
+                    (("g_test_add_func \\(\"/gdbus/message-serialize/double-array\", test_double_array\\);" all)
+                     (string-append "/* " all " */"))))
                 %standard-phases)
 
       ;; Note: `--docdir' and `--htmldir' are not honored, so work around it.