summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-08 15:12:46 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:27 -0500
commit0268db5671df74d25fea5f0d7fe26ded6afc6d7b (patch)
treea035e05fd83828c5a917b6a6174151f9adcdef05 /gnu
parent5ce79ae7405fb030613703a03eb675d8d2cf263c (diff)
downloadguix-0268db5671df74d25fea5f0d7fe26ded6afc6d7b.tar.gz
gnu: gst-libav: Update to 1.18.5.
* gnu/packages/gstreamer.scm (gst-libav): Update to 1.18.5.
[source]: Remove patch, now integrated upstream.
* gnu/packages/patches/gst-libav-64channels-stack-corruption.patch: Delete file.
* gnu/local.mk: De-register it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gstreamer.scm5
-rw-r--r--gnu/packages/patches/gst-libav-64channels-stack-corruption.patch31
3 files changed, 2 insertions, 35 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 6ec789a376..5efc6dd4df 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1215,7 +1215,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/grub-efi-fat-serial-number.patch		\
   %D%/packages/patches/grub-setup-root.patch			\
   %D%/packages/patches/gspell-dash-test.patch			\
-  %D%/packages/patches/gst-libav-64channels-stack-corruption.patch	\
   %D%/packages/patches/gst-plugins-good-fix-test.patch		\
   %D%/packages/patches/guile-1.8-cpp-4.5.patch			\
   %D%/packages/patches/guile-2.2-skip-oom-test.patch            \
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index e03da788f6..227f2c9b27 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -960,7 +960,7 @@ think twice about shipping them.")
 (define-public gst-libav
   (package
     (name "gst-libav")
-    (version "1.18.4")
+    (version "1.18.5")
     (source
      (origin
        (method url-fetch)
@@ -968,9 +968,8 @@ think twice about shipping them.")
         (string-append
          "https://gstreamer.freedesktop.org/src/" name "/"
          name "-" version ".tar.xz"))
-       (patches (search-patches "gst-libav-64channels-stack-corruption.patch"))
        (sha256
-        (base32 "15n3x3vhshqa3icw93g4vqmqd46122anzqvfxwn6q8famlxlcjil"))))
+        (base32 "0j55jgk9sbhinfx2gsg21q609x6yzrixrn5xxlxd378fj6500bl2"))))
     (build-system meson-build-system)
     (native-inputs
      `(("perl" ,perl)
diff --git a/gnu/packages/patches/gst-libav-64channels-stack-corruption.patch b/gnu/packages/patches/gst-libav-64channels-stack-corruption.patch
deleted file mode 100644
index cc174e618d..0000000000
--- a/gnu/packages/patches/gst-libav-64channels-stack-corruption.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Fix a stack corruption when handling files with more than 64 audio
-channels:
-
-https://gstreamer.freedesktop.org/security/sa-2021-0005.html
-
-Patch copied from upstream source repository:
-
-https://gitlab.freedesktop.org/gstreamer/gst-libav/-/commit/dcea8baa14a5fc3b796d876baaf2f238546ba2b1
-
-diff --git a/ext/libav/gstavcodecmap.c b/ext/libav/gstavcodecmap.c
-index b5be4bb7a5f2712f78383da9319754a8849e3307..be22f22cf5c7c7b22b13e44b10999adaacbcca2b 100644
---- a/ext/libav/gstavcodecmap.c
-+++ b/ext/libav/gstavcodecmap.c
-@@ -102,7 +102,7 @@ gst_ffmpeg_channel_layout_to_gst (guint64 channel_layout, gint channels,
-   guint nchannels = 0;
-   gboolean none_layout = FALSE;
- 
--  if (channel_layout == 0) {
-+  if (channel_layout == 0 || channels > 64) {
-     nchannels = channels;
-     none_layout = TRUE;
-   } else {
-@@ -163,7 +163,7 @@ gst_ffmpeg_channel_layout_to_gst (guint64 channel_layout, gint channels,
-     } else {
-       guint i;
- 
--      for (i = 0; i < nchannels; i++)
-+      for (i = 0; i < nchannels && i < 64; i++)
-         pos[i] = GST_AUDIO_CHANNEL_POSITION_NONE;
-     }
-   }