summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-03-16 12:16:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-03-16 12:16:15 +0200
commit030900747b27643c73400a806ebabc00d9a943ff (patch)
treed5a861da5686efb4d168ddc950edcb588235fde9 /gnu
parent32f52f82b3206f27669ba89d0f6f657e3f389ec3 (diff)
downloadguix-030900747b27643c73400a806ebabc00d9a943ff.tar.gz
Revert "gnu: Add %final-inputs-riscv64."
This reverts commit 0444be868903356a37fc8ffd3cdf820ca038f3e6.

This is no longer necessary after the gcc STARTFILE_PREFIX_SPEC commit.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 9b495d8d84..efd840d67c 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3737,19 +3737,6 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
       ("libc:static" ,glibc-final "static")
       ("locales" ,glibc-utf8-locales-final))))
 
-(define-public %final-inputs-riscv64
-  ;; This is similar to the added (list gcc "lib") elsewhere in this file, but
-  ;; due to how (%current-system) is re-defined when performing builds with the
-  ;; 'gnu.system' flag, %final-inputs is too early in the evaulation pipeline to
-  ;; correctly identify the system for which a derivation will be built. Thus,
-  ;; since (%current-system) is re-determined by (guix build-system gnu) after
-  ;; loading %final-inputs but before taking into account the 'gnu.system' flag,
-  ;; the test for (target-riscv64?) needs to be in (guix build-system gnu),
-  ;; with %final-inputs-riscv64 already available at the same time that
-  ;; %final-inputs is available.
-  `(("gcc:lib" ,gcc-final "lib")
-    ,@%final-inputs))
-
 (define-public canonical-package
   (let ((name->package (fold (lambda (input result)
                                (match input