summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-01-14 17:28:54 -0500
committerLudovic Courtès <ludo@gnu.org>2022-01-23 23:20:51 +0100
commit0406aa2b8f6a9bd6beab9780f7554aa265eb2c28 (patch)
tree0f508c7a46410c8e7f7468a55c99757abaf50a69 /gnu
parentaeeaf4eef40811d2f934cff914ba31dbbf04d449 (diff)
downloadguix-0406aa2b8f6a9bd6beab9780f7554aa265eb2c28.tar.gz
gnu: rofi: Add a search path for plugins.
* gnu/packages/xdisorg.scm (rofi)[native-search-paths]: Add ROFI_PLUGIN_PATH.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 865ffdb61f..eb94a00561 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -52,6 +52,7 @@
 ;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1718,6 +1719,11 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
            xcb-util-cursor
            xcb-util-wm
            xcb-util-xrm))
+    (native-search-paths
+     ;; This is where rofi will search for plugins by default.
+     (list (search-path-specification
+            (variable "ROFI_PLUGIN_PATH")
+            (files '("lib/rofi")))))
     (arguments
      `(#:parallel-tests? #f             ; fails in some circumstances
        #:phases