summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZheng junjie <873216071@qq.com>2021-06-11 20:52:59 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-13 19:14:04 +0200
commit0bba028e65c6c0305345a7025a205282b2f22b91 (patch)
tree479dce1be669a85129cffa32b32028b7a66f79f9 /gnu
parent3e825016cbd9f255181bc925c8a8c0f7da757205 (diff)
downloadguix-0bba028e65c6c0305345a7025a205282b2f22b91.tar.gz
gnu: Add rust-xshell-macros-0.1.
* gnu/packages/crates-io.scm (rust-xshell-macros-0.1): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1789607f4f..84205e3b05 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -52492,6 +52492,28 @@ to XDG Base Directory specification.")
 parser.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-xshell-macros-0.1
+  (package
+    (name "rust-xshell-macros")
+    (version "0.1.13")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "xshell-macros" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0lkym5kfq446xymimxr226kppr3ynpi9n8iif32vrfbm5i5djzng"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page "https://github.com/matklad/xshell")
+    (synopsis
+     "Private implementation detail of xshell crate")
+    (description
+     "This package provide a private implementation detail of xshell crate.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-xz2-0.1
   (package
     (name "rust-xz2")