summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 02:46:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:46 -0400
commit0e406da6a07dbafbc4422294956878057508131a (patch)
tree3e3ecb884590ccdc0c9e9fa4bd2c8b634e3e29a5 /gnu
parentcdbfe93f164c1621be4e0e0558c3529ff0c720c8 (diff)
downloadguix-0e406da6a07dbafbc4422294956878057508131a.tar.gz
gnu: Remove python2-pycairo.
* gnu/packages/gtk.scm (python2-pycairo): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm19
1 files changed, 1 insertions, 18 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2518b98756..a15d2be1a6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1919,26 +1919,9 @@ printing and other features typical of a source code editor.")
     (synopsis "Python bindings for cairo")
     (description
      "Pycairo is a set of Python bindings for the Cairo graphics library.")
-    (license license:lgpl3+)
-    (properties `((python2-variant . ,(delay python2-pycairo))))))
+    (license license:lgpl3+)))
 
 ;; Pycairo no longer supports Python 2 since version 1.19.0, so we stick
-;; with this older version here.
-(define-public python2-pycairo
-  (let ((pycairo (package-with-python2
-                  (strip-python2-variant python-pycairo))))
-    (package
-      (inherit pycairo)
-      (version "1.18.2")
-      (source (origin
-                (method url-fetch)
-                (uri (string-append "https://github.com/pygobject/pycairo/releases"
-                                    "/download/v" version "/pycairo-" version ".tar.gz"))
-                (sha256
-                 (base32
-                  "0cb5n4r4nl0k1g90b1gz9iyk4lp7hi03db98i1p52a870bym7f6w"))))
-      ;; Dual-licensed under LGPL 2.1 or Mozilla Public License 1.1
-      (license (list license:lgpl2.1 license:mpl1.1)))))
 
 (define-public perl-cairo
   (package