summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSamuel Fadel <samuel@nihil.ws>2022-06-30 09:58:34 +0200
committerLudovic Courtès <ludo@gnu.org>2022-07-13 00:20:05 +0200
commit20693769d621625266b871738eb494df067bc15f (patch)
treebcbf60283beba3fe0cadbd89bd93c65769a15a65 /gnu
parent3bfd7eaaebef0f263d0535c21d5fe71e441c25ff (diff)
downloadguix-20693769d621625266b871738eb494df067bc15f.tar.gz
gnu: Add breeze-gtk.
* gnu/packages/kde-plasma.scm (breeze-gtk): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-plasma.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 5621d8ea35..2317cbec5a 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -31,11 +31,14 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages qt)
-  #:use-module (gnu packages xorg))
+  #:use-module (gnu packages xorg)
+  #:use-module (gnu packages web))
 
 (define-public breeze
   (package
@@ -83,6 +86,30 @@
 the Plasma Desktop.  Breeze is the default theme for the KDE Plasma desktop.")
     (license license:gpl2+)))
 
+(define-public breeze-gtk
+  (package
+    (name "breeze-gtk")
+    (version "5.19.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/plasma/"
+                                  version "/" name
+                                  "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1j2nq9yw1ragmgwrz9f6ca4ifpi86qv1bbprdgd2qm2yh7vb44sj"))))
+    (build-system qt-build-system)
+    (arguments
+     '(#:tests? #f))                              ;no 'test' target
+    (native-inputs (list breeze extra-cmake-modules sassc python
+                         python-pycairo))
+    (home-page "https://invent.kde.org/plasma/breeze")
+    (synopsis "Default KDE Plasma theme (GTK+ port)")
+    (description "GTK+ port of the Breeze visual style for the Plasma Desktop.
+Breeze is the default theme for the KDE Plasma desktop.")
+    (license (list license:bsd-3                  ;cmake/FindSass.cmake
+                   license:lgpl2.1+))))           ;<all other files>
+
 (define-public kdecoration
   (package
     (name "kdecoration")