summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-23 12:14:39 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-23 12:14:39 +0200
commit2f1a01b7cd7763ec55c9334b84013a30a3ded96f (patch)
tree3e36cfc3817ad969285508df80f59a1cbf97a9e0 /gnu
parentb69ce8a8721ad82a528acc21bed68e611e5c6114 (diff)
downloadguix-2f1a01b7cd7763ec55c9334b84013a30a3ded96f.tar.gz
gnu: mit-scheme: Pass a valid tarball hash on non-x86.
Fixes this bug:

  $ guix build -nd mit-scheme -s aarch64-linux
  guix build: error: derivation `/gnu/store/…-mit-scheme-c-10.1.3.tar.gz.drv' has incorrect output `/gnu/store/…-mit-scheme-c-10.1.3.tar.gz', should be `/gnu/store/…-mit-scheme-c-10.1.3.tar.gz'

This is a followup to 7d6cfa442539e8fda0c145bf7a774c13e4fdc83c.

* gnu/packages/scheme.scm (mit-scheme)[inputs]: For "source", pass a
hash of the right length in the catch-all case.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/scheme.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 9962cbdcb5..5753035643 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -204,8 +204,8 @@
               (base32
                "05sjyz90xxfnmi87qv8x0yx0fcallnzl1dciygdafp317pn489is"))
              (_
-               (base32
-                ""))))))))
+              (base32
+               "aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa"))))))))
 
     ;; Fails to build on MIPS, see <http://bugs.gnu.org/18221>.
     ;; Also, the portable C version of MIT/GNU Scheme did not work in time for