summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-04 15:35:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-04 15:55:00 +0200
commit2f2ef63141c37c72e2c52aac8d5807f356ddec43 (patch)
treefadd4bc8e27e4d209dad8b186d0a90ec4a2fd29c /gnu
parent3a104c5f9d5e5b22dde9fcd31e3fa39537984667 (diff)
downloadguix-2f2ef63141c37c72e2c52aac8d5807f356ddec43.tar.gz
gnu: Add r-keras.
* gnu/packages/cran.scm (r-keras): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ad1427d388..3262ee9ef4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30153,3 +30153,36 @@ flow graphs.  Nodes in the graph represent mathematical operations, while the
 graph edges represent the multidimensional data arrays (tensors) communicated
 between them.")
     (license license:asl2.0)))
+
+(define-public r-keras
+  (package
+    (name "r-keras")
+    (version "2.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "keras" version))
+       (sha256
+        (base32
+         "00bw5f5d81md8db1k6bf2a91by4k25xvlwxiwv188y4vw3bfc7md"))))
+    (properties `((upstream-name . "keras")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-generics" ,r-generics)
+       ("r-magrittr" ,r-magrittr)
+       ("r-r6" ,r-r6)
+       ("r-reticulate" ,r-reticulate)
+       ("r-rlang" ,r-rlang)
+       ("r-tensorflow" ,r-tensorflow)
+       ("r-tfruns" ,r-tfruns)
+       ("r-zeallot" ,r-zeallot)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://keras.rstudio.com")
+    (synopsis "R Interface to 'Keras'")
+    (description
+     "This package provides an interface to Keras, a high-level neural
+networks API.  Keras was developed with a focus on enabling fast
+experimentation, supports both convolution based networks and recurrent
+networks (as well as combinations of the two), and runs seamlessly on both CPU
+and GPU devices.")
+    (license license:expat)))