summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-06-30 10:05:50 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-06-30 10:18:51 +0200
commit33b54ef2a57d361ec680e975c4617352478d6657 (patch)
tree973f44c8a17e06f9ccc3c5c54e8ea2896f0bfaf8 /gnu
parent387b66b643a796df33d4fcb30549559dadcf0e0f (diff)
downloadguix-33b54ef2a57d361ec680e975c4617352478d6657.tar.gz
gnu: python-k5test: Apply unreleased upstream fix.
* gnu/packages/python-xyz.scm (python-k5test) [arguments]<#:phases>:
Rename phase to reflect what it actually does, add another substitute*
expression.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bb28120c25..e655b3b20e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23286,10 +23286,13 @@ and cuts down boilerplate code when testing libraries for asyncio.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-paths
+         (add-after 'unpack 'apply-upstream-fixes
            (lambda* _
              (substitute* "k5test/realm.py"
-               (("'kadmin_local'") "'kadmin.local'")))))))
+               ;; Upstream commit f6b302d94dbdce37a1b81cc3faeeac4dc637b0e9.
+               (("'kadmin_local'") "'kadmin.local'")
+               ;; Upstream commit 3aef84515cf3d1a171c66856c898d0a5cbbd03ea.
+               (("\\.stop_daemon") "._stop_daemon")))))))
     (home-page "https://github.com/pythongssapi/k5test")
     (synopsis "Library for setting up self-contained Kerberos 5 environments")
     (description