summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-26 09:10:30 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-26 09:16:04 +0200
commit5ac097e28c3b654ae7ae821e757599e1738e23aa (patch)
treed7acd4ce384392571df990a472c87f448ff72075 /gnu
parent82654d956fd381cb10a7878758b25074636e757d (diff)
downloadguix-5ac097e28c3b654ae7ae821e757599e1738e23aa.tar.gz
gnu: libpqxx: Fix build with newer sed.
* gnu/packages/databases.scm (libpqxx)[arguments]: Add 'fix-sed-command' phase
that corrects a typo in the configure script.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8b01a2f01b..be92c416fb 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1349,7 +1349,15 @@ trees (LSM), for sustained throughput under random insert workloads.")
      `(("python" ,python-2)))
     (inputs `(("postgresql" ,postgresql)))
     (arguments
-     `(#:tests? #f)) ; # FAIL:  1
+     `(#:tests? #f   ; # FAIL:  1
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-sed-command
+           (lambda _
+             ;; Newer sed versions error out if double brackets are not used.
+             (substitute* "configure"
+               (("\\[:space:\\]") "[[:space:]]"))
+             #t)))))
     (synopsis "C++ connector for PostgreSQL")
     (description
      "Libpqxx is a C++ library to enable user programs to communicate with the