summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:27:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:10 +0200
commit6c960872086bbed20b80a1dfa4f31cd108a168fe (patch)
tree04abd321e78b791fe3033d62d7f9347430656ed9 /gnu
parentee9ee9946f5cfb06b47fa80a925a1cc798c37903 (diff)
downloadguix-6c960872086bbed20b80a1dfa4f31cd108a168fe.tar.gz
gnu: emacs-ansi: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-ansi)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c7356ea9d6..565ffa3562 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7241,13 +7241,13 @@ lines, and @code{gc} to comment out the target of a motion.")
     (version "0.4.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/rejeep/ansi.el/archive/v"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rejeep/ansi.el.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "13jj4vbi98j3p17hs99bmy7g21jd5h4v3wpxk4pkvhylm3bfwjw8"))))
+        (base32 "1hbddxarr40ygvaw4pwaivq2l4f0brszw73w1r50lkjlggb7bl3g"))))
     (build-system emacs-build-system)
     (propagated-inputs
      `(("emacs-dash" ,emacs-dash)