summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-29 18:22:16 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-29 20:44:30 +0100
commit70feedbbdb202bd0366121bd766d1838b20233d7 (patch)
tree1f6112015422ae4e862418d1522a193bbf8f09ed /gnu
parent79613ec8fc2bedc838f5ef211fbbae6e241a54a3 (diff)
downloadguix-70feedbbdb202bd0366121bd766d1838b20233d7.tar.gz
gnu: prixovy: Enable HTTPS inspection.
* gnu/packages/tor.scm (privoxy)[arguments]: Add "--with-openssl"
to the #:configure-flags.
[inputs]: Add openssl.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tor.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 6ab64645b6..1aa261ddd2 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -171,7 +171,8 @@ rejects UDP traffic from the application you're using.")
        #:configure-flags (list (string-append "--sysconfdir="
                                               (assoc-ref %outputs "out")
                                               "/etc/privoxy")
-                               "--localstatedir=/var")
+                               "--localstatedir=/var"
+                               "--with-openssl")
        #:tests? #f                      ; no test suite
        #:phases
        (modify-phases %standard-phases
@@ -193,8 +194,9 @@ rejects UDP traffic from the application you're using.")
                  (("^logfile") "#logfile")))
              #t)))))
     (inputs
-     `(("w3m" ,w3m)
+     `(("openssl" ,openssl)
        ("pcre" ,pcre)
+       ("w3m" ,w3m)
        ("zlib" ,zlib)))
     (native-inputs
      `(("autoconf" ,autoconf)