summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-23 01:14:22 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:11 -0400
commit9fd911eb9b6e55e5586314605f0074f95f190466 (patch)
tree1783fbc601b8978aefaf8cb2d52a97b332ee44fa /gnu
parent09fccde9c04769ecf01bc5c6a22aadc9704369e5 (diff)
downloadguix-9fd911eb9b6e55e5586314605f0074f95f190466.tar.gz
gnu: Add python-mpl-sphinx-theme.
* gnu/packages/sphinx.scm (python-mpl-sphinx-theme): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sphinx.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index ae0080b308..93f174217a 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -748,6 +748,23 @@ Sphinx documentation system, used by @uref{http://docs.guzzlephp.org, Guzzle}
 and several other projects.")
     (license license:expat)))
 
+(define-public python-mpl-sphinx-theme
+  (package
+    (name "python-mpl-sphinx-theme")
+    (version "3.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mpl_sphinx_theme" version))
+       (sha256
+        (base32 "0ilsw6s5hfvjzqs3258c8gmg5v3dwa6k69mwmkxsyh1qmv15krpw"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pydata-sphinx-theme))
+    (home-page "https://github.com/matplotlib/mpl-sphinx-theme")
+    (synopsis "Matplotlib theme for Sphinx")
+    (description "This package provides a Matplotlib theme for Sphinx.")
+    (license license:bsd-3)))
+
 (define-public python-sphinx-rtd-theme
   (package
     (name "python-sphinx-rtd-theme")