summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-08-28 23:56:10 +0200
committerLudovic Courtès <ludo@gnu.org>2019-08-28 23:57:17 +0200
commitc55fae452032aa4b1b63406983e9abdf70adc957 (patch)
tree87e206379c27c641a313e80920486d421d43ec91 /gnu
parent7f1d2dd35a317724058e89734cd2ec73828c82c7 (diff)
downloadguix-c55fae452032aa4b1b63406983e9abdf70adc957.tar.gz
gnu: bison-boot0: Build sequentially.
This is a followup to 2c35ae82192fd6f1732b15fa41aec87aa61a1879 and
b1593c1c4fd8f4fc6df4c43cab51334426e3aa76.

* gnu/packages/commencement.scm (bison-boot0)[arguments]: Add
 #:parallel-build? and #:parallel-tests? on x86.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 69d1f87605..79f2e49008 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1719,6 +1719,17 @@ exec " gcc "/bin/" program
                   (arguments
                    `(#:tests? #f                  ;... and thus disable tests
 
+                     ;; XXX: These flags should be unconditional, but for now
+                     ;; we just add them on x86 to avoid a full rebuild.
+                     ;; TODO: On the next core-updates, use
+                     ;; 'substitute-keyword-arguments' to inherit them from
+                     ;; BISON.
+                     ,@(if (member (%current-system)
+                                   '("x86_64-linux" "i686-linux"))
+                           '(#:parallel-build? #f
+                             #:parallel-tests? #f)
+                           '())
+
                      ;; Zero timestamps in liby.a; this must be done
                      ;; explicitly here because the bootstrap Binutils don't
                      ;; do that (default is "cru".)