summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-21 19:13:37 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-21 22:35:58 +0100
commite11a70176dca55fe60e5ab5dc967028920d0968b (patch)
tree47dda57ae5be1bd0fc2d798bed953716ec2a59bc /gnu
parenta63179196eee2e690e027f3619a0121dfc9475cd (diff)
downloadguix-e11a70176dca55fe60e5ab5dc967028920d0968b.tar.gz
gnu: go@1.9: Drop left-over work-around.
* gnu/packages/golang.scm (go-1.9)[arguments]: Remove substitution for
fixed bug from the ‘prebuild’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm7
1 files changed, 0 insertions, 7 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e7c2d228cc..b80abed493 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -300,13 +300,6 @@ sequential processes (CSP) concurrent programming features added.")
                  (substitute* "../misc/cgo/testcarchive/carchive_test.go"
                    (("#!/usr/bin/env") (string-append "#!" (which "env"))))
 
-                 ;; Escape braces in test data to workaround test failure. For
-                 ;; more information:
-                 ;; https://github.com/golang/go/issues/20007
-                 ;; FIXME: remove this once we upgrade to 1.9
-                 (substitute* "cmd/vet/testdata/copylock_func.go"
-                   (("struct\\{lock sync.Mutex\\}") "struct\\{lock sync.Mutex\\}"))
-
                  (substitute* "net/lookup_unix.go"
                    (("/etc/protocols") (string-append net-base "/etc/protocols")))
                  (substitute* "net/port_unix.go"