summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-26 19:21:33 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-26 19:21:33 +0100
commitf85722d9d7eeed3413a2aa50f2915788451c0bcd (patch)
tree0489936103ea879b7333c889b7370e2021abc8ac /gnu
parent3142daccbe9caf8b1189a60f2974e0c938c77abf (diff)
downloadguix-f85722d9d7eeed3413a2aa50f2915788451c0bcd.tar.gz
gnu: Add python-setuptools-scm/next.
* gnu/packages/python-xyz.scm (python-setuptools-scm/next): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a9493fe31b..d243083f3c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6533,6 +6533,18 @@ child application and control it as if a human were typing commands.")
 them as the version argument or in a SCM managed file.")
     (license license:expat)))
 
+;; TODO: Merge with 'python-setuptools-scm' on the next rebuild cycle.
+(define-public python-setuptools-scm/next
+  (package
+    (inherit python-setuptools-scm)
+    (version "5.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "setuptools_scm" version))
+       (sha256
+        (base32 "0ahlrxxkx2xhmxskx57gc96w3bdndflxx30304ihvm7ds136nny8"))))))
+
 (define-public python2-setuptools-scm
   (package-with-python2 python-setuptools-scm))