summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-19 21:52:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:04 -0400
commitfa84f9bce9e1ddd7c513268962bd4779a0b1dc3d (patch)
tree5c841d2402aa3358916d3c650178d77643734ea5 /gnu
parent3ddeaf90a69a4392a3638649ef25025db01a9271 (diff)
downloadguix-fa84f9bce9e1ddd7c513268962bd4779a0b1dc3d.tar.gz
gnu: python-miio: Update to 0.5.11.
* gnu/packages/android.scm (python-miio): Update to 0.5.11.
[phases]{relax-requirements}: New phase.
{adjust-for-click-8}: Likewise.
{check}: Remove extraneous add-installed-pythonpath call, INPUTS and OUTPUTS
arguments.  Invoke pytest with -vv.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/android.scm22
1 files changed, 16 insertions, 6 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 9f00303811..04dc4b6499 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2016, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2017, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2017, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2019, 2020 Andreas Enge <andreas@enge.fr>
@@ -1078,23 +1078,33 @@ backups.  It supports encrypted archives.")
 (define-public python-miio
   (package
     (name "python-miio")
-    (version "0.5.8")
+    (version "0.5.11")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "python-miio" version))
        (sha256
         (base32
-         "0a4f5ybjvibawwxcjm3r9nnrzf1yff6wwgy05yzyk0bb3rmc99fp"))))
+         "1dyzzywfa5h6q8clmzxsqmszlby8757ajmvkhdyvq6719z4bn46n"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'relax-requirements
+           (lambda _
+             (substitute* "setup.py"
+               (("cryptography>=35")
+                "cryptography"))))
+         (add-after 'unpack 'adjust-for-click-8
+           (lambda _
+             (substitute* '("miio/integrations/vacuum/roborock/vacuum.py"
+                            "miio/integrations/vacuum/roborock/vacuum_cli.py")
+               (("resultcallback")
+                "result_callback"))))
          (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+           (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "pytest" "miio")))))))
+               (invoke "pytest" "-vv" "miio")))))))
     (native-inputs
      (list python-pytest
            python-pytest-mock