summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 05:45:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 06:28:27 +0200
commit1fc346de4eb6881c087eae2c603a761b510e28f2 (patch)
treecef3a1adcc716413bdde32cc18115d668c78e577 /gnu
parentfe30eb6d24dd750a124cb0c1f6300fc3d5518d7f (diff)
downloadguix-1fc346de4eb6881c087eae2c603a761b510e28f2.tar.gz
gnu: retroarch: Don't use unstable tarball.
* gnu/packages/emulators.scm (retroarch)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emulators.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 443137f141..a07ce29243 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1058,12 +1058,13 @@ emulation community.  It provides highly accurate emulation.")
     (version "1.7.4")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/libretro/RetroArch/archive/v"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/libretro/RetroArch.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0h6y2hpjg4b470jvn9ghwp0k3a527sbb6xhia17frlm9w9v5028w"))))
+        (base32 "1gagdwydj6kl3gzi9z1rjgrbjvi325f8159fdaryzf5gjj8avp8m"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no tests