summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2017-06-04 20:57:03 -0700
committerArun Isaac <arunisaac@systemreboot.net>2017-06-08 19:56:17 +0530
commit45f523d9f018c262900e94b0f70f17b05118941c (patch)
tree1d6cc67cba8cb3b8beea80c23a9eb6836d3b5041 /gnu
parentdf34f478944217b8621315acbe21d1f1dd63f4be (diff)
downloadguix-45f523d9f018c262900e94b0f70f17b05118941c.tar.gz
gnu: emacs: Fix ert-runner by adding 'reporters' subdirectory.
Previous this change, ert-runner would fail with error:
"Invalid reporter: dot".

* gnu/packages/emacs.scm (ert-runner)[include]: Add regexp to match elisp
files under the 'reporters' subdirectory.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 987aaf4226..a4cb4a0b3a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4814,7 +4814,8 @@ Emacs.")
                           ;; determined by emacs' standard initialization
                           ;; procedure
                           (list ""))))
-                 #t))))))
+                 #t))))
+         #:include (cons* "^reporters/.*\\.el$" %default-include)))
       (home-page "https://github.com/rejeep/ert-runner.el")
       (synopsis "Opinionated Ert testing workflow")
       (description "@code{ert-runner} is a tool for Emacs projects tested