summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-13 11:54:14 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-13 13:52:15 -0500
commit5a96dc03c73ad533c4a22eaf3044dccd24a526c8 (patch)
tree28e9f2ca1701fa5658ca4ff37238ca12422d35a4 /gnu
parent77917f67fdfe5e563f8e983e79f3bc05de927f47 (diff)
downloadguix-5a96dc03c73ad533c4a22eaf3044dccd24a526c8.tar.gz
gnu: Add Moo.
* gnu/packages/perl.scm (perl-moo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0e804abd4e..e72614786f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1748,6 +1748,37 @@ which had a recent release that broke some versions of Moose.  It is called
 from Moose::Conflicts and moose-outdated.")
     (license (package-license perl))))
 
+(define-public perl-moo
+  (package
+    (name "perl-moo")
+    (version "1.007000")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
+                           "Moo-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0y9s6s9jjd519wgal6lwc9id4sadrvfn8gjb51dl602d0kk0l7n5"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-fatal" ,perl-test-fatal)))
+    (propagated-inputs
+     `(("perl-class-method-modifiers" ,perl-class-method-modifiers)
+       ("perl-class-xsaccessor" ,perl-class-xsaccessor)
+       ("perl-devel-globaldestruction" ,perl-devel-globaldestruction)
+       ("perl-import-into" ,perl-import-into)
+       ("perl-module-runtime" ,perl-module-runtime)
+       ("perl-role-tiny" ,perl-role-tiny)
+       ("perl-strictures" ,perl-strictures)))
+    (home-page "http://search.cpan.org/dist/Moo")
+    (synopsis "Minimalist Object Orientation (with Moose compatibility)")
+    (description "Moo is an extremely light-weight Object Orientation system.
+It allows one to concisely define objects and roles with a convenient syntax
+that avoids the details of Perl's object system.  Moo contains a subset of
+Moose and is optimised for rapid startup.")
+    (license (package-license perl))))
+
 (define-public perl-moose
   (package
     (name "perl-moose")