summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-04 00:37:59 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-04 18:03:45 +0100
commit635dd0cc96a5d06933a52a48bb9520efbd567550 (patch)
tree1bdb67132821662eb278a1f5a43f0b1ab0ce267c /gnu
parent9539016e3addb4bd5b4adfab27334131a532a11c (diff)
downloadguix-635dd0cc96a5d06933a52a48bb9520efbd567550.tar.gz
gnu: tomb: Update phase style.
* gnu/packages/crypto.scm (tomb)[arguments]: Substitute INVOKE for
SYSTEM* and end phases with #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crypto.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 7cac132b64..b498aabf4d 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -384,9 +384,9 @@ no man page, refer to the home page for usage details.")
          (delete 'configure)   ;no configuration to be done
          (add-after 'install 'i18n
            (lambda* (#:key make-flags #:allow-other-keys)
-             (zero? (apply system*
-                           "make" "-C" "extras/translations"
-                           "install" make-flags))))
+             (apply invoke "make" "-C" "extras/translations"
+                    "install" make-flags)
+             #t))
          (add-after 'install 'wrap
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
@@ -411,7 +411,8 @@ no man page, refer to the home page for usage details.")
              ;; querying `tomb -h`.
              (let ((tomb (string-append (assoc-ref outputs "out")
                                         "/bin/tomb")))
-               (zero? (system* tomb "dig" "-s" "10" "secrets.tomb"))))))))
+               (invoke tomb "dig" "-s" "10" "secrets.tomb")
+               #t))))))
     (home-page "https://www.dyne.org/software/tomb")
     (synopsis "File encryption for secret data")
     (description