summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2017-09-01 22:14:55 +0800
committer宋文武 <iyzsong@member.fsf.org>2017-09-11 19:07:56 +0800
commit6bda496286149911bb0ba460c35a144ef4109cc0 (patch)
tree5a80d0582fa6369b6cd29ce43e03587cbae1a180 /gnu
parent130c3bc8948cb249129b3310561d9a2553926a60 (diff)
downloadguix-6bda496286149911bb0ba460c35a144ef4109cc0.tar.gz
gnu: icedtea-8: Install the nss.cfg file to JRE.
Before this, accessing HTTPS will throw an exception about 'nss.cfg' could not
be found.

* gnu/packages/java.scm (icedtea-8)[arguments]: Copy 'nss.cfg' from JDK into
JRE in the install phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index f361697b2b..806f13ab89 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1628,6 +1628,10 @@ IcedTea build harness.")
                    (copy-recursively "openjdk.build/docs" doc)
                    (copy-recursively "openjdk.build/images/j2re-image" jre)
                    (copy-recursively "openjdk.build/images/j2sdk-image" jdk)
+                   ;; Install the nss.cfg file to JRE to enable SSL/TLS
+                   ;; support via NSS.
+                   (copy-file (string-append jdk "/jre/lib/security/nss.cfg")
+                              (string-append jre "/lib/security/nss.cfg"))
                    #t)))))))
       (native-inputs
        `(("jdk" ,icedtea-7 "jdk")