summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2017-01-08 20:08:16 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-08 23:38:49 +0100
commit84bf2a2e74b3f40e150554d0f8d3bce1986b8089 (patch)
tree896d16d8933e8edd2a79d42abbbbf4aac19f5eeb /gnu
parent5b4946180e26177ad574d23e1c52489e4a0576ee (diff)
downloadguix-84bf2a2e74b3f40e150554d0f8d3bce1986b8089.tar.gz
gnu: prosody: Make config and data files visible to 'prosodyctl'.
* gnu/packages/messaging.scm (prosody)[arguments]: Add a 'fix-makefile' phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 21928789c6..2be3b09695 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -536,6 +536,14 @@ end-to-end encryption support; XML console.")
              (substitute* "configure"
                (("exit 1") ""))
              #t))
+         (add-after 'unpack 'fix-makefile
+           (lambda _
+             (substitute* "Makefile"
+               ;; prosodyctl needs to read the configuration file.
+               (("^INSTALLEDCONFIG =.*") "INSTALLEDCONFIG = /etc/prosody\n")
+               ;; prosodyctl needs a place to put auto-generated certificates.
+               (("^INSTALLEDDATA =.*") "INSTALLEDDATA = /var/lib/prosody\n"))
+             #t))
          (add-after 'install 'wrap-programs
            (lambda* (#:key inputs outputs #:allow-other-keys)
              ;; Make sure all executables in "bin" find the required Lua