summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-14 17:39:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-14 17:39:50 +0100
commit8fdc843f26fd0cdbfb3fca679b6cc9f2b4feacc9 (patch)
treee42facfebfa60d459166c528a59f5b33668b0e71 /gnu
parent8c72ed923d77ee55989965bb02628043799b9548 (diff)
downloadguix-8fdc843f26fd0cdbfb3fca679b6cc9f2b4feacc9.tar.gz
gnu: Ungraft glibc.
* gnu/packages/base.scm (glibc-2.26-patched): Remove variable.
(glibc/linux)[replacement]: Remove.
[source]: Add "glibc-allow-kernel-2.6.32.patch" to patches.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index f630ccec2b..1481cad274 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -544,7 +544,6 @@ store.")
    ;; Note: Always use a dot after the minor version since various places rely
    ;; on "version-major+minor" to determine where locales are found.
    (version "2.26.105-g0890d5379c")
-   (replacement glibc-2.26-patched)
    (source (origin
             (method url-fetch)
             (uri (string-append "https://alpha.gnu.org/gnu/guix/mirror/"
@@ -563,7 +562,8 @@ store.")
             (modules '((guix build utils)))
             (patches (search-patches "glibc-ldd-x86_64.patch"
                                      "glibc-versioned-locpath.patch"
-                                     "glibc-o-largefile.patch"))))
+                                     "glibc-o-largefile.patch"
+                                     "glibc-allow-kernel-2.6.32.patch"))))
    (build-system gnu-build-system)
 
    ;; Glibc's <limits.h> refers to <linux/limit.h>, for instance, so glibc
@@ -847,14 +847,6 @@ GLIBC/HURD for a Hurd host"
 ;; Below are old libc versions, which we use mostly to build locale data in
 ;; the old format (which the new libc cannot cope with.)
 
-(define glibc-2.26-patched
-  (package
-    (inherit glibc)
-    (source (origin
-              (inherit (package-source glibc))
-              (patches (cons (search-patch "glibc-allow-kernel-2.6.32.patch")
-                             (origin-patches (package-source glibc))))))))
-
 (define-public glibc-2.25
   (package
     (inherit glibc)