summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTonton <tonton@riseup.net>2018-05-17 17:50:33 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-19 22:14:48 +0200
commitd282fee549c2bad9f413bada5f398aa220f84429 (patch)
treec9d375bf2f9932e0ccdfb6a5f1f4c9c5d71697cc /gnu
parent05ca7a916a54d32ae4603bcd90918fb19e907704 (diff)
downloadguix-d282fee549c2bad9f413bada5f398aa220f84429.tar.gz
gnu: Add zyre.
* gnu/packages/networking.scm (zyre): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index eda2984d10..7e69a48b84 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -20,6 +20,7 @@
 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2018 Adam Van Ymeren <adam@vany.ca>
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
+;;; Copyright © 2018 Tonton <tonton@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1768,3 +1769,36 @@ allowing you to run a client with no graphical interface, and a Web GUI for
 remote access.  The @command{amulecmd} command allows you to control aMule
 remotely.")
     (license license:gpl2+)))
+
+(define-public zyre
+  (package
+    (name "zyre")
+    (version "2.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append "https://github.com/zeromq/zyre/releases/download/v"
+                              version "/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0qz2730bng1gs9xbqxhkw88qbsmszgmmrl2g9k6xrg6r3bqvsdc7"))))
+    (build-system gnu-build-system)
+    (inputs `(("zeromq" ,zeromq)
+              ("czmq" ,czmq)
+              ("libsodium" ,libsodium)))
+    (synopsis "Framework for proximity-based peer-to-peer applications")
+    (description "Zyre provides reliable group messaging over local area
+networks using zeromq.  It has these key characteristics:
+
+@itemize
+@item Zyre needs no administration or configuration.
+@item Peers may join and leave the network at any time.
+@item Peers talk to each other without any central brokers or servers.
+@item Peers can talk directly to each other.
+@item Peers can join groups, and then talk to groups.
+@item Zyre is reliable, and loses no messages even when the network is heavily loaded.
+@item Zyre is fast and has low latency, requiring no consensus protocols.
+@item Zyre is designed for WiFi networks, yet also works well on Ethernet networks.
+@end itemize")
+    (home-page "https://github.com/zeromq/zyre")
+    (license license:mpl2.0)))