summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 21:06:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 22:00:25 +0200
commit080093ff6a5be997ec1458a8d0e0ca300ee3fc46 (patch)
treeb41e848c63bb3271680f037d477f445f6455b055 /gnu
parent13151c326a2fb97d2d10e8fcf68d4bba15f20d1e (diff)
downloadguix-080093ff6a5be997ec1458a8d0e0ca300ee3fc46.tar.gz
gnu: eid-mw: Fix build.
* gnu/packages/security-token.scm (eid-mw)[arguments]: Move the
‘bootstrap’ phase to after ‘unpack’. Modify it to run without errors,
and call upstream's bootstrap.sh script instead of our own copy.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/security-token.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index eb89c2a5ca..4619b83921 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -121,9 +121,14 @@ readers and is needed to communicate with such devices through the
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         ;; The github tarball doesn't contain a configure script.
-         (add-before 'configure 'autoreconf
-           (lambda _ (zero? (system* "autoreconf" "-i")))))))
+         (add-after 'unpack 'bootstrap
+           (lambda _
+             ;; configure.ac relies on ‘git --describe’ to get the version.
+             ;; Patch it to just return the real version number directly.
+             (substitute* "scripts/build-aux/genver.sh"
+               (("/bin/sh") (which "sh"))
+               (("\\$GITDESC") ,version))
+             (invoke "sh" "./bootstrap.sh"))))))
     (synopsis "Belgian eID Middleware")
     (description "The Belgian eID Middleware is required to authenticate with
 online services using the Belgian electronic identity card.")