summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-14 09:15:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-14 09:15:49 +0200
commit1dd153b3aabcc05e2ed3863ea0571985c0cae307 (patch)
tree63530061524741aacc6c9ed5982730d06e5f1b2b /gnu
parent6ffffb3c96779cdbec692e3d8e20281f258d660f (diff)
downloadguix-1dd153b3aabcc05e2ed3863ea0571985c0cae307.tar.gz
gnu: Add python-hic2cool.
* gnu/packages/bioinformatics.scm (python-hic2cool): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f6410c3ca4..67f24a6170 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13699,3 +13699,27 @@ are highly customizable.  Currently, it is possible to plot: bigwig, bed (many
 options), bedgraph, links (represented as arcs), and Hi-C matrices.
 pyGenomeTracks can make plots with or without Hi-C data.")
     (license license:gpl3+)))
+
+(define-public python-hic2cool
+  (package
+    (name "python-hic2cool")
+    (version "0.4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hic2cool" version))
+       (sha256
+        (base32
+         "0xy6mhfns2lzib1kcr6419jjp6pmh0qx8z8na55lmiwn0ds8q9cl"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f)) ; no tests included
+    (propagated-inputs
+     `(("python-cooler" ,python-cooler)))
+    (home-page "https://github.com/4dn-dcic/hic2cool")
+    (synopsis "Converter for .hic and .cool files")
+    (description
+     "This package provides a converter between @code{.hic} files (from
+juicer) and single-resolution or multi-resolution @code{.cool} files (for
+cooler).  Both @code{hic} and @code{cool} files describe Hi-C contact
+matrices.")
+    (license license:expat)))