summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-08 10:44:05 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-08 16:02:33 +0800
commit50cc7f41b9620d37552b0a777d8a7e8500d06418 (patch)
tree078bf460674fcd693bafd438292506493eefc41d /gnu
parentc6a552daea6eae8f6cc47696cc407ba5c2b5d4da (diff)
downloadguix-50cc7f41b9620d37552b0a777d8a7e8500d06418.tar.gz
gnu: at-spi2-core: Enable GObject introspection.
* gnu/packages/gtk.scm (at-spi2-core)[arguments]: Add #:make-flags.
  [native-inputs]: Add gobject-introspection.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index bfc898935e..338bf64db7 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -344,7 +344,8 @@ in the GNOME project.")
               "1l3l39mw23zyjlcqidvkyqlr4gwbhplzw2hcv3qvn6p8ikxpf2qw"))))
    (build-system gnu-build-system)
    (arguments
-    '(#:phases
+    '(#:make-flags '("CC=gcc") ; for g-ir-scanner
+      #:phases
       (modify-phases %standard-phases
         (replace check
                  ;; Run test-suite under a dbus session.
@@ -358,8 +359,9 @@ in the GNOME project.")
     `(("libxi" ,libxi)
       ("libxtst" ,libxtst)))
    (native-inputs
-     `(("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)))
+    `(("gobject-introspection" ,gobject-introspection)
+      ("intltool" ,intltool)
+      ("pkg-config" ,pkg-config)))
    (synopsis "Assistive Technology Service Provider Interface, core components")
    (description
     "The Assistive Technology Service Provider Interface, core components,